Au backe… flattr LogoFür das letzte Update habe ich mir einiges an Schelte eingefahren. Ich ahnte, dass die Code-Zusammenlegung in das Flattr-Hauptplugin nicht leicht wird. Zum Glück haben viele Blogger sehr verständnisvoll reagiert und durch zahlreiche eMails nützliche Informationen zur Fehlereingrenzung beigesteuert.

Das Update auf 0.9.21.1 des WordPress Plugin steht ab sofort zum Download bereit!

Allesblog#flattr
    • tanalahy
    • Bei mir bleibt nach dem Update auf Version 0.9.22 der gesamt Admin Bereich leer!

    • tanalahy
    • Ja, nur der Teil von Flattr. Der HTML Code wird an den Browser ausgeliefert, aber nicht dargestellt. Als ob ein Code-Fehler die Ausgabe verhindert, ein “hidden” Attribut am Werke sei oder das JS für die Tabs nicht greift. Könnte Dir die HTML-Datei per Mail senden?

    • alexolma
    • Version 0.9.22 installiert. Ebenfalls der Flattr-Adminbereich bleibt komplett leer.

      Lässt sich das irgendwie reparieren? Danke!

    • Michael Henke
    • Habt ihr JavaScript-Blocker (NoScript) laufen, oder mal einen anderen Browser ausprobiert? Normalweise sollte das tabber.js script die CSS Classe nach dem vollständigen Laden wechseln und somit die Tabs anzeigen.

    • alexolma
    • Nee, es laufen keine JavaScript-Blocker und diverse andere Browser habe ich ebenfalls ausprobiert…

    • tanalahy
    • Nein kein JS-Blocker, getestet mit Firefox 3.6.13 und MSE 6.0

    • Michael Henke
    • Im Source könnt ihr erkennen, dass das File tabber.js geladen werden soll. Existiert es an der Stelle auf eurem Server? Wenn nicht, wo liegt es stattdessen?

    • alexolma
    • Existiert, ja (/flattr/tabber.js). Ist aber mit dem Verweis (inaktiv) versehen?

    • tanalahy
    • Genau @Michael, jetzt müsste ich den Quellcode manuell anpassen. Besser wäre es, das vom Programmierer direkt abzufangen. Viele installieren WordPress so wie ich in einem Unterverzeichnis. Manche Themes haben dieses Problem auch. Mal sehen, welche Code-Zeile geändert werden muss…

    • Michael Henke
    • Ich kann mir vorstellen, dass in der flattr/settings-template.php die Zeile

      get_settings(‘home’)

      in

      get_settings(‘siteurl’)

      geändert werden müsste…

    • tanalahy
    • Nö, ‘siteurl’ greift bei mir nicht, benutze bis zu besseren Lösungen die harte Tour bei Line 322:

      $plugindir = get_settings(‘home’).’/weblog/wp-content/plugins/’.dirname(plugin_basename(__FILE__));

    • tanalahy
    • OK, @Michael, get_settings(‘siteurl’) ist die richtige Lösung – hatte nur an der falschen Stelle die alte Zeile 322 auskommentiert. Danke für das Brainstorming! Ist mir einen Flattr wert 😉

    • Michael Henke
    • Danke fürs verifizieren! 😉

      Ich hab das gleich ins nächste Bugfix-Release mit übernommen.

    • alexolma
    • Die Änderungen in flattr/settings-template.php zeigen bei mir leider keine Auswirkungen…

    • tanalahy
    • Hab da noch eine Frage in diesem Kontext: Wie kann ich die aktivierte Option “Automatic Submission” nahc einem Testlauf wieder deaktivieren. Sie ist bei mir nach erfolgreicher Aktivierung leider ausgegraut.

    • Michael Henke
    • Ist auf jeden Fall für das nächste Update geplant!